Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#652 closed defect (fixed)

Crash with analytical spinup after 95 years

Reported by: luyssaert Owned by: luyssaert
Priority: critical Milestone: IPSLCM6.v2
Component: Biogeochemical processes Version:
Keywords: Cc:

Description

The crash is in the high arctic (lat=81N, lon=31W) after 95 years in
production mode. Looks like a new crash from stomate_growth_fun_all. The crash was reproduced in a 3 by 3 test case on obelix in debug mode and pointed to a floating invalid on line 5137 in stomate_growth_fun_all.f90

  optimal_share =(-labile_pool + SQRT(labile_pool**2 - 4 * reserve_pool * &
                     (-tmp_bm(ipts,j,icarbres,icarbon) - tmp_bm(ipts,j,ilabile,icarbon)))) / &
                     (2 * reserve_pool)

Change History (5)

comment:1 Changed 8 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r6463 stomate_growth_all_fun.f90. The reserve pool was zero because lai_target became zero which in turn was caused by a leaf mass of 10e-14. Despite the very low leaf, root and sapwood masses the PFT contained 10e-5 labile and reserve carbon. Such a masses are not viable. Some code was added to prevent the divide by a zero reserve_pool. It is anticipated that this PFT will die soon in the proper subroutines. A warning was added to the out_orchidee file.

comment:2 Changed 8 months ago by luyssaert

  • Resolution fixed deleted
  • Status changed from closed to reopened

When launching a global run on irene the model crashed in year 1 with a mass balance error. The error could be reproduced on obelix.

22 Error: mass balance is not closed in littercalc for carbon
22 ipts, ivm; 86 13
22 Difference is, -240304.005384266
22 pool_end,pool_start: 0.000000000000000E+000 -240304.005384266
22
22FATAL ERROR FROM ROUTINE littercalc
22 --> Mass balance error
22 -->
22 -->
22
The lat lon are:

22pixel number to lat/lon: 86 13.0000000000 93.0000000000

comment:3 Changed 8 months ago by luyssaert

Fixed in r6464. tree_ff was set to 1 instead of -9999 avoiding the big negative value. tree_ff is now used in the calculation of KF for grasses and crops.

comment:4 Changed 8 months ago by luyssaert

Floating point exception in condveg.f90 on line:

z0h(:) = ztmp(:) / EXP((ct_karman**2.)/(dragh(:)*LOG(ztmp(:)/z0m(:)

comment:5 Changed 8 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from reopened to closed

This error was caused by a large negative dragh (-1400) which in turn was caused by an unrealistic height that was caused by the using old parameters in combination with r6461. New parameters were committed in r6468 and r6469.

Last edited 8 months ago by luyssaert (previous) (diff)
Note: See TracTickets for help on using tickets.