#671 closed defect (fixed)

Grassland crashing in phenology in global run FG2

Reported by: mmcgrath Owned by: gmarie
Priority: critical Milestone: IPSLCM6.v2
Component: Physical processes Version:
Keywords: Cc:

Description

In OPT mode on Irene, FG2 crashes in year 41 with r6522 (31 CPUs, 1 CPU for XIOS).

5vkdnovz pixel number to lat/lon: 41 65.0000000000 159.0000000000
5 Date: 1945-06-12 0.0000sec at timestep 778657
5 Entering phenology
5 About to crash
5 ipts, ivm: 41 15
5 KF(ipts,ivm): 0.243759106705145
5 Cs_grass: 0.000000000000000E+000
5 circ_class_biomass icarbon: 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000
5 circ_class_biomass initrogen: 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000 0.000000000000000E+000 0.000000000000000E+000
5 0.000000000000000E+000
5 circ_class_n: 0.000000000000000E+000
5 plant_status, 3.00000000000000
5
5FATAL ERROR FROM ROUTINE stomate_phenology
5 --> We are getting ready to divide by zero. It is possible that KF is zero
5 --> or that Cs_grass is zero. This has been observed to happen when a PFT died last year
5 --> but did not regrow due to trace carbon left in the labile pool.
5
5Fatal error from ORCHIDEE. STOP in ipslerr_p with code

Change History (4)

comment:1 Changed 14 months ago by luyssaert

Could not reproduce this crash with a 3x3 test case on a single processor on obelix. May have to fix ticket 659 first.

comment:2 Changed 14 months ago by luyssaert

A possible fix has been committed in r6549

comment:3 Changed 14 months ago by luyssaert

  • Owner changed from somebody to gmarie
  • Status changed from new to assigned

comment:4 Changed 14 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.