Opened 3 years ago

Last modified 12 months ago

#691 accepted defect

pb with orchideedriver compiled in debug mode

Reported by: jgipsl Owned by: jgipsl
Priority: major Milestone: Not scheduled yet
Component: Driver files Version:
Keywords: Cc:

Description

The "new driver" orchideedriver does not run in debug mode, using revision 6651 of the trunk. The error occurs in forcing_checkindex where the variable testvar is used but not allocated (it is an input variable to this subroutine).

When running using compilation in production mode, the model does not crash but the file forcing_mask_glo.nc seems not correct for the variable TAIR. The file forcing_maks_loc.nc is correct.

forcing_mask_glo.nc can be deactivated by putting .FALSE. in CALL forcing_getglogrid which will then send a .FALSE. to CALL forcing_checkindex . It makes sens to set FALSE in tha CALL forcing_getglogrid because the forcing file is closed just before, see comments in forcing_getglogrid.

Change History (3)

comment:1 Changed 3 years ago by jgipsl

  • Component changed from Anthropogenic processes to Driver files

forcing_mask_glo.nc has been deactivated in following changset [6652]. The orchideedriver now runs while compiled with debug or prod options, tested at irene.

Should this be seen as a temporary solution or can the ticket be closed?

comment:2 Changed 2 years ago by luyssaert

  • Milestone set to Not scheduled yet

comment:3 Changed 12 months ago by jgipsl

  • Owner changed from somebody to jgipsl
  • Status changed from new to accepted
Note: See TracTickets for help on using tickets.