Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#747 closed defect (fixed)

Global FM maps - mass balance error

Reported by: mmcgrath Owned by: luyssaert
Priority: blocker Milestone: ORCHIDEE 4.1
Component: Anthropogenic processes Version:
Keywords: Cc:

Description

When launching FG1 for 15PFTs and one age class with r6963 on Irene with 128 CPUs in production mode (127 CPUs on ORCHIDEE, 1 CPU for XIOS), I ran into a mass balance error on CPU 72.

72pixel number to lat/lon: 8 33.0000000000 71.0000000000

72 Error: mass balance is not closed in stomate_allocation for carbon
72 ipts, ivm; 8 3
72 Difference is, -1.917267054627796E-002
72 pool_end,pool_start: 124.091026258324 124.110007202165
72
72FATAL ERROR FROM ROUTINE stomate_allocation
72 --> Mass balance error
72 -->
72 -->
72
72Fatal error from ORCHIDEE. STOP in ipslerr_p with code

The only difference between this run and the SVN version are turning off forced forest management and using the FM maps:

~/SCRIPTS/diff_config_dir.sh ../FG1.FM.r6963 ../SPINUP_ANALYTIC_FG1
*
Running diff for config.card.
15c15
< JobName=FG1.FM.r6963
---

JobName=anspin

17c17
< LongName="New formulation of maintantence respiration (temperature dependence, matching TAG 3.0) and updated parameters. Using FM maps."
---

LongName=""

20c20
< SpaceName=PROD
---

SpaceName=TEST

60c60
< OOL= (orchidee_ol_${OptMode}, orchidee_ol, 127MPI)
---

OOL= (orchidee_ol_${OptMode}, orchidee_ol, 31MPI)

*
Running diff for PARAM/orchidee.def.
34c34,35
< OK_READ_FM_MAP=y
---

OK_READ_FM_MAP=n
FOREST_MANAGED_FORCED=1

*
Running diff for PARAM/run.def.
*
Running diff for PARAM/orchidee_pft.def_15pft.1ac.
*
Running diff for PARAM/iodef_xios1.xml.
*
Running diff for PARAM/iodef_xios2.xml.
*
Running diff for PARAM/iodef.xml.
*
Running diff for PARAM/orchidee_pft.def_13pft.1ac.
*
Running diff for PARAM/orchidee_pft.def_28pft.1ac.
*
Running diff for PARAM/orchidee_pft.def_37pft.4ac.
*
Running diff for PARAM/orchidee_pft.def_3pft.1ac.
*
Running diff for PARAM/orchidee_pft.def_64pft.4ac.
*
Running diff for COMP/stomate.card.
*
Running diff for COMP/stomate.driver.
*
Running diff for COMP/sechiba.card.
*
Running diff for COMP/sechiba.driver.
*
Running diff for COMP/orchidee_ol.card.
*
Running diff for COMP/orchidee_ol.driver.
*
Running diff for COMP/xios.card.
*
Running diff for COMP/xios.driver.
*
Finished.

Change History (3)

comment:1 Changed 12 months ago by luyssaert

  • Owner changed from somebody to luyssaert
  • Status changed from new to accepted

comment:2 Changed 11 months ago by mmcgrath

  • Resolution set to fixed
  • Status changed from accepted to closed

Using the most recent version of the code, r6980, I was unable to reproduce this (the crash happened in the first year, and now the code makes it to the end of the first year and crashes in XIOS....see ticket #752).

Therefore, I'm closing this ticket for now.

comment:3 Changed 11 months ago by mmcgrath

Sebastiaan also mentioned to me that he could not reproduce the bug on obelix using the recent version of the code.

Note: See TracTickets for help on using tickets.