#760 closed defect (fixed)

Steady state of spinup

Reported by: luyssaert Owned by: somebody
Priority: major Milestone: ORCHIDEE 4.1
Component: Biogeochemical processes Version: trunc
Keywords: Cc:

Description

In revision r7040 the vegetation biomass reaches a steady state after around 600 years. This is seems to be quite a lot given that we don't expect many forests to grow older than 200 to 300 years.

Check: whether this long time period to reach steady state can be ascribed to a single of few PFTs. If so check the self-thinning parameters of these PFTs.

In revision r7040 the soil has not yet reached equilibrium after 600 years resulting in an NBP of 0.309 Pg C/yr. This is more than 3 times higher than the equilibrium NBP in tag 2.2.

Check: the soil is expected to be running behind the vegetation. Could be that soil reaches equilibrium a few decades later. In r7040 grasses need to be replanted too often (this hints at a bug -> #728). Crops need to be replanted annually (by conception -> not a bug). This means that we keep adding nitrogen to the soil and thus change the soil fertility. This could result in some transient behavior (although a steady state should occur after some time but we don't know how long "some" is).

Attachments (3)

labile_biomass_PFTs.gif (7.8 KB) - added by luyssaert 17 months ago.
total_biomass_PFTs.gif (9.1 KB) - added by luyssaert 17 months ago.
reserve_biomass_PFTs.gif (7.8 KB) - added by luyssaert 17 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 17 months ago by luyssaert

The biomass of PFT8 increases for almost 600 years after which it saturates. PFT8 contributes considerably to the global biomass (see attached figure, Y-axis is in Pg C). The biomass of PFT9 is still linearly increasing after 650 years but its global contribution is much smaller (see attached figure, Y-axis is in Pg C). If we could speed up the period in which PFT8 could reach a steady state biomass, PFT2 would become the bottleneck because its biomass increases (slowly) between 300 and 650 years (see figure). Given that PFT2 dominates the global biomass, a relatively small increase could still be seen in the NBP.

comment:2 Changed 17 months ago by mmcgrath

An extended spinup to 1000 years has been finished for r7013.

https://vesg.ipsl.upmc.fr/thredds/fileServer/work/mcgrathm/OL2/PROD/spinup/FG1.FM1.r7013/MONITORING/index.html#tabs-2

The NBP is not going to zero, instead staying positive, even when the average is taken over 300 years.

yes? list NBP_FLUX_C_LANDS[l=700:1000@ave]
             T        : 699.5 to 1000.5 (averaged)
          0.4065

yes? list NBP_FLUX_C_LANDS[l=800:1000@ave]
             T        : 799.5 to 1000.5 (averaged)
          0.4183

yes? list NBP_FLUX_C_LANDS[l=900:1000@ave]
             T        : 899.5 to 1000.5 (averaged)
          0.3957

Changed 17 months ago by luyssaert

Changed 17 months ago by luyssaert

Changed 17 months ago by luyssaert

comment:3 Changed 15 months ago by luyssaert

Committed code to reduce synchronicity during the spinup in r7143.

comment:4 Changed 10 months ago by luyssaert

With r7278 the NBP is stable and of the same order of magnitude albeit of different sign as ORC2 and ORC3. ORC4 simulates as ink of 0.136 Pg C y-1. Following parameterization of sugar_loading and autothropic respiration, the labile+reserve carbon and biomass reached equilibrium (reflected in the stable NBP). The remaining sink is thought to be due to the fact that the N-cycle is not completely closed and that new N enters the system when replanting occurs. For crops this is annually. For semi-arid and arid grasslands this annually or once every couple of years. A possible solution is proposed in ticket #793.


comment:5 Changed 10 months ago by luyssaert

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.