Opened 3 years ago

Closed 3 years ago

#768 closed defect (fixed)

Mass balance error in grasslands

Reported by: mmcgrath Owned by: luyssaert
Priority: major Milestone: ORCHIDEE 4.1
Component: Anthropogenic processes Version:
Keywords: Cc:

Description

Using a production executable on Irene with global FG1 (analytical spinup) runs with r7134 resulted in similar crashes for three slightly different runs: mass balance errors in grasslands. This involved tests with different forcings (CRUJRA and CRUNCEP) as well as both the old and the new driver.

FG1.JRAod.r7134
28pixel number to lat/lon:     14       61.0000000000       -7.0000000000
28 Error: mass balance is not closed in stomate_allocation for carbon
28  ipts, ivm;           14          10
28  Difference is,   1.247612539632694E-008
28  pool_end,pool_start:    705.492300015322        705.492300029385
28
28FATAL ERROR FROM ROUTINE stomate_allocation
28 --> Mass balance error
28 -->
28 -->
28
28Fatal error from ORCHIDEE. STOP in ipslerr_p with code
^L

FG1.JRAnd.r7134
95pixel number to lat/lon:     13       61.0000000000       -7.0000000000
95 Error: mass balance is not closed in stomate_allocation for carbon
95  ipts, ivm;           13          10
95  Difference is,   1.005964445323248E-008
95  pool_end,pool_start:    768.555764016132        768.555764027479

FG1.NCEPod.r7134
33pixel number to lat/lon:      3       59.0000000000       -7.0000000000
33 Error: mass balance is not closed in stomate_allocation for carbon
33  ipts, ivm;            3          10
33  Difference is,   1.156936236221751E-008
33  pool_end,pool_start:    643.430255110319        643.430255123065
33
33FATAL ERROR FROM ROUTINE stomate_allocation
33 --> Mass balance error
33 -->
33 -->
33
33Fatal error from ORCHIDEE. STOP in ipslerr_p with code

Change History (7)

comment:1 Changed 3 years ago by mmcgrath

I should also mention that the crashes happened after 110 years (exact year varies depending on the run, but year 111, 114, and 175, with year 175 being for CRUNCEP and the other two for CRUJRA).

comment:2 follow-up: Changed 3 years ago by mmcgrath

Using r7173, the same error still seems to be present on Irene, with a production executable, 127 CPUs, for the global analytical spinup run from SVN.

29 Entering functional allocation growth
29 Error: mass balance is not closed in stomate_allocation for carbon
29  ipts, ivm;           24          10
29  Difference is,   1.016107965661175E-008
29  pool_end,pool_start:    2047.01447724276        2047.01447725560
29
29FATAL ERROR FROM ROUTINE stomate_allocation
29 --> Mass balance error
29 -->
29 -->
29
29Fatal error from ORCHIDEE. STOP in ipslerr_p with code

I will change ERR_ACT to be 1 and re-launch.

comment:3 in reply to: ↑ 2 Changed 3 years ago by mmcgrath

Replying to mmcgrath:

The crash happens in year 71.

Using r7173, the same error still seems to be present on Irene, with a production executable, 127 CPUs, for the global analytical spinup run from SVN.

29 Entering functional allocation growth
29 Error: mass balance is not closed in stomate_allocation for carbon
29  ipts, ivm;           24          10
29  Difference is,   1.016107965661175E-008
29  pool_end,pool_start:    2047.01447724276        2047.01447725560
29
29FATAL ERROR FROM ROUTINE stomate_allocation
29 --> Mass balance error
29 -->
29 -->
29
29Fatal error from ORCHIDEE. STOP in ipslerr_p with code

I will change ERR_ACT to be 1 and re-launch.

comment:4 Changed 3 years ago by mmcgrath

The error happens in the following pixel.

29pixel number to lat/lon: 24 61.0000000000 -7.0000000000

comment:5 Changed 3 years ago by luyssaert

  • Owner changed from somebody to luyssaert
  • Status changed from new to accepted

comment:6 Changed 3 years ago by luyssaert

The problem was caused by setting b_inc_tot to zero when it was less than min_stomate. This resulted in some real loss of carbon. Following this crash the model crashed in year 91 on another mass balance check. The initial bm_alloc_tot was more than min_stomate but when the available nitrogen was accounted for no more than 1e-9 g C were left to be allocated. Given this is less than 1e-8 it should not have been allocated. Both issues were fixed in r7180. The pixel could be run for a 340 year long spinup.

Last edited 3 years ago by luyssaert (previous) (diff)

comment:7 Changed 3 years ago by luyssaert

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.