Opened 3 months ago

Closed 13 days ago

#845 closed enhancement (fixed)

Develop functionality to run single pixels with SAFRAN forcing

Reported by: luyssaert Owned by: somebody
Priority: major Milestone: ORCHIDEE 4.3
Component: Driver files Version: trunc
Keywords: Cc:

Description (last modified by jgipsl)

Intial tests showed that it is not possible to run a single pixel or a smaller domain within the SAFRAN grid (confirmed by Jan Polcher). Having this functionality is essential for efficient debugging and could come in handy for fast testing and/or regional studies.

Change History (6)

comment:1 Changed 3 months ago by jgipsl

Last edited 3 months ago by jgipsl (previous) (diff)

comment:2 Changed 3 months ago by jgipsl

  • Description modified (diff)

comment:3 Changed 3 months ago by xnwang

Ran some test simulation with SAFRAN over a small region, and there is an error:

FATAL ERROR FROM ROUTINE forcing_open

--> At least one of the dimensions of the grid obtained from the
--> grid file is different from the one in the forcing file.
--> Run driver2oasis -init to generate a new grid file.

Fatal error from IOIPSL. STOP in ipslerr with code

According to Jan P., some modification of code is necessary. The modification can be a bit more complex since we need to preserve in the zoom the existing projections lon,lat = f(i,j) and i,j=f'(lat,lon).

comment:4 Changed 2 months ago by xnwang

First modification is applied to globgrd.f90 in rev [7647] in the trunk, by discussing with Jan. A test of regional simulation runs with SAFRAN forcing file now.

It seems that some projection method may need be added to the code, in order that the selection of Safran pixels would be more accurate for example.

Last edited 8 weeks ago by jgipsl (previous) (diff)

comment:5 Changed 2 weeks ago by xnwang

In rev 7714, modifications were added to forcing_tools.f90, globgrd.f90 and orchideedriver.f90, to make sure of good selection of region and projection method when using SAFRAN forcing (with WRF grids).

Compiled in prod mode. Multiple test were made, over zoomed or full domain, using safran or crujra forcing, with 1 or multiple MPIs. These tests passed.

comment:6 Changed 13 days ago by xnwang

  • Resolution set to fixed
  • Status changed from new to closed

Tested in debug mode. Several small concerns were detected, which also appears in some previous revisions of trunk, including the tagged revision. These concerns are not related to this ticket.

Though they seem not crucial to the orchidee functionality, they will be reported in another ticket for the information of group.

Note: See TracTickets for help on using tickets.