Opened 6 years ago

Closed 6 years ago

#63 closed defect (invalid)

Complementing field definition by sourcing from an alternate file does not work

Reported by: ssenesi Owned by: ymipsl
Priority: major Component: XIOS
Version: 1.0 Keywords:
Cc: rlacroix

Description

When wanting to add some field definition by sourcing an alternate file, you should be able to write :

<field_definition> <field id="default_field"domain_ref="FULL"></field_definition>
<field_definition id="field_definition" src="./surfex_base.xml" />

where the content of surfex_base.xml is e.g. :
<field_definition > <field id="LE" name="leprime" /> </field_definition>

This crashes XIOS with "MPI_ERR_COMM: invalid communicator" (while putting the equivalent content at the same place in the master xml file works fine)

Change History (3)

comment:1 Changed 6 years ago by rlacroix

  • Cc rlacroix added

It might just be a typo in the ticket description but you have a / missing in your XML example: <field id="default_field"domain_ref="FULL"> should be <field id="default_field"domain_ref="FULL" />.

Here is what I tried with the sample test_client application and iodef.xmlconfiguration file we distribute with XIOS:

   <field_definition> <field id="default_field" domain_ref="FULL" /></field_definition>
   <field_definition id="field_definition" src="./field_def.xml" /> 

with field_def.xml:

   <field_definition level="1" enabled=".FALSE.">
     <field id="field_A"  operation="average" freq_op="3600s" domain_ref="domain_A"  axis_ref="axis_A" />
   </field_definition>

Using this modified example with the trunk version, I could not reproduce the issue you are reporting. Are you using the stable branch or the trunk and at which revision exactly?

Note that if I keep the typo in the field definition, XIOS shows an error as expected but it doesn't crash either.

I might have overlooked something though.

Last edited 6 years ago by rlacroix (previous) (diff)

comment:2 Changed 6 years ago by ssenesi

OK. Issue is solved (wth 1.0 r29) : I had a typo, at another location.

Sorry, and thanks

Season's greetings !

comment:3 Changed 6 years ago by rlacroix

  • Resolution set to invalid
  • Status changed from new to closed

No problem!

PS: I guess you meant r529 because r29 really is old. :)

Note: See TracTickets for help on using tickets.