Opened 6 years ago

Closed 6 years ago

#65 closed defect (fixed)

Regression caused by automatic detection of buffer size

Reported by: rlacroix Owned by: mhnguyen
Priority: major Component: XIOS
Version: 2.0 Keywords: regression, buffer
Cc:

Description

As far as I can tell the automatic detection of buffer size is causing two issues (closely related):

  • XIOS will raise an error if a context has no enabled output file which it has no good reasons to do.
  • XIOS can fail if internal messages are bigger than the estimated output data.

This can probably be solved by always allocating a buffer with a fixed minimum size we know will always be sufficient to allocate the internal messages.

Change History (2)

comment:1 Changed 6 years ago by mhnguyen

The problem is solved by allocating the buffer with a minimum size equal to size of the largest internal message

comment:2 Changed 6 years ago by mhnguyen

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.