Opened 4 years ago

Closed 3 years ago

#122 closed defect (fixed)

regression with detect_missing_value between 1013 and 1029

Reported by: ssenesi Owned by: ymipsl
Priority: major Component: XIOS
Version: 2.0 Keywords:
Cc:

Description

I am time-averaging fields (snow albedoes) which are both :

  • defined with a mask and
  • showing missing values at time-varying location

I am also remapping these fields to grid complete' : a rectilinear grid with gaussian latitudes

In Xios parlance, it writes :

<file id="EXPID_test_4D" output_freq="6h" >

<field_group domain_ref="complete" expr="@this">

<field field_ref="albs" name="albs_avg" operation="average" detect_missing_value="true"/>

</field_group>

</file>

The result is fine with XIOS 1013 : locations which do not always have a defined values do show senesible values
However, with XIOS 1029, they show values which obviously are averaged n samples whare the mssing value (here 1.e+20) is considered as a valid value

Change History (4)

comment:1 Changed 4 years ago by ssenesi

Additional information : "instant" fields are OK

comment:2 Changed 4 years ago by ssenesi

XIos team explained me that, from some release between 1013 and 1029, due to a basic change in missing_values handling, you know have to declare a default_value for the target field

comment:3 Changed 4 years ago by ssenesi

However, it would make sense that filters which have one single input flux let their output flux inherit the default value set for this input flux

comment:4 Changed 3 years ago by ymipsl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.