Changes between Version 69 and Version 70 of ticket/1851/General


Ignore:
Timestamp:
2017-03-31T11:00:16+02:00 (3 years ago)
Author:
frrh
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • ticket/1851/General

    v69 v70  
    576576Footnotes on code generally: 
    577577 
    578    1) MEDUSA's use of modules needs tidying and in particular it needs to clarify what comes from where using ONLY statements.  
    579    2) par_trca and oce_trc are included in trc, but  trc_sms_medusa does a USE of these THREE things separately. This needs rationalising.  
    580    3) trcbio_medusa as noted repeatedly elsewhere is unsustainably large and needs splitting up to facilitate clarity, maintenance, debugging and future development.  
    581    4) trcbio_medusa and possibly other routines abound with the use of magic numbers in array indices to identify certain fields.   
     578   * MEDUSA's use of modules needs tidying and in particular it needs to clarify what comes from where using ONLY statements.  
     579   * par_trca and oce_trc are included in trc, but  trc_sms_medusa does a USE of these THREE things separately. This needs rationalising.  
     580   * trcbio_medusa as noted repeatedly elsewhere is unsustainably large and needs splitting up to facilitate clarity, maintenance, debugging and future development.  
     581   * trcbio_medusa and possibly other routines abound with the use of magic numbers in array indices to identify certain fields. These should be changed to use (PARAMETER) variables with meaningful names to aid clarity and coding when fields need to be referred to in different places.