Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#1129 closed Bug (fixed)

Agrif and s-coordinates

Reported by: jchanut Owned by: nemo
Priority: low Milestone:
Component: AGRIF Version: release-3.5
Severity: Keywords:
Cc:

Description

There is a problem with AGRIF and s-coordinates caused by the arbitrary value chosen for vertical scale factors over land (1m). Baroclinic velocity obcs in AGRIF are indeed written as a weighted average over 3 lines(columns) across the boundary. Since fluxes and not velocities are exchanged between grids, one need a meaningful value of vertical scale factors at the fine grid ghost points (ie at the outermost masked points of the domain).
To fix that, one can duplicate needed scale factors in domzgr. Note that in z-coord, the problem (almost) does not arise, because background scale factors are set to the reference values.

Commit History (1)

ChangesetAuthorTimeChangeLog
3967cbricaud2013-07-10T14:43:23+02:00

Vertical scale factors with sco and AGRIF, see ticket #1129

Change History (3)

comment:1 Changed 7 years ago by jchanut

  • Component changed from OPA to AGRIF

comment:2 Changed 7 years ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by nicolasmartin

  • Keywords agrif removed
Note: See TracTickets for help on using tickets.