Opened 7 years ago

Closed 7 years ago

#1209 closed Bug (fixed)

Time splitting + key_vvl: Call to wzv prior vertical scale factor update

Reported by: jchanut Owned by: nemo
Priority: normal Milestone:
Component: OCE Version: release-3.6
Severity: Keywords:
Cc:

Description

A pre-estimate of vertical velocity is needed for time splitting. wn computation requires "after" vertical scale factors to be computed, hence a call to dom_vvl_sf_nxt. This is unfortunately not done so that momentum advection tendency is wrong.

No issue without key_vvl.

A quick fix for zstar coordinate is to make sea level appear in wzv routine (updated in ssh_nxt at the beginning of the step) in place of vertical scale factors.

For ztilde: this is more problematic…

Commit History (2)

ChangesetAuthorTimeChangeLog
4387jchanut2014-01-31T14:48:39+01:00

Correct call to dom_vvl_sf_nxt (impacts ztilde and dynspg_flt only): ticket #1209

4338acc2013-12-17T17:33:09+01:00

Branch dev_MERGE_2013. #1209. Fix to compute after scale factors before wn computation in time-splitting case. dom_vvl_sf_nxt is now called twice but correctly computes the baroclinic contribution only once. Still need to sort out the asselin filtering of the separate components

Change History (3)

comment:1 follow-up: Changed 7 years ago by sallen@…

Would this problem also affect the tracer (T&S) advection?

comment:2 in reply to: ↑ 1 Changed 7 years ago by jchanut

Replying to sallen@…:

Would this problem also affect the tracer (T&S) advection?

The problem is fixed now. It did not impact tracer's conservation, just momentum trend.

comment:3 Changed 7 years ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.