Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#1319 closed Task (fixed)

2014 Work Plan Met Office Task 10: 25hour Mean Diagnostic

Reported by: deazer Owned by: nemo
Priority: low Milestone:
Component: OCE Version: trunk
Severity: Keywords: 25hr_mean XIOS tides
Cc: smasson Review:
MP ready?:
Progress:

Description

Add simple 25 hour mean Diagnostic

Allows a simple mean based on 25 instantaneous values of variable of interest (ssh,T,S,U,V) to calculate a crude 25 hour mean for roughly removing dominant M2 tidal signal.

This has the advantage that the mean can be done within a 24 hour cycle useful for operational
output. (does not require data before or after current day)

Currently implemented in Met office branch in NEMO, better would be to have it entirely implemented XIOS side.


Commit History (0)

(No commits)

Change History (8)

comment:1 Changed 6 years ago by deazer

Last edited 6 years ago by deazer (previous) (diff)

comment:2 Changed 6 years ago by deazer


Last edited Timestamp?


Author : Enda O'Dea
ticket : #1319

Branch : https://forge.ipsl.jussieu.fr/nemo/browser/branches/2014/dev_r4650_UKMO10_Tidally_Meaned_Diagnostics


Description

Introduced new routines to deal with 25hour mean and Top,MIddle and Bottom Diagnostics.
TMB cab probably be done by IOS as is but have included it here just in case it cannot.

  • dia25h.F90 (new)
    • SUBROUTINE dia_25h_init
      • Read namelist whether to output 25h or not. Allocates 25h arrays if true.

Called in *nemo_init*

  • SUBROUTINE dia_25h
    • adds instantaneous values of t,s,sshn, and insitu_t ( this is calculated in a new routine diainsitutem.F90 (SUBROUTINE theta2t)
    • outputs using iom (xml files adjusted accordingly for the new fields)
  • diatmb.F90 (new)
    • SUBROUTINE dia_tmb_init
      • inits logical form namelist if we want tmb or not
    • SUBROUTINE dia_calctmb
      • takes an input 3d field and returns the top mid and bottom based on mbathy as and array of 3 2d layers.
    • SUBROUTINE dia_tmb calls dia_calctmb and then uses iom to otput 2d fields of top, mid and bot fields of t, s and also outputs ssh.
  • diainsitutem.F90 (new)
    • SUBROUTINE theta2t
      • Converts Potential to insitu temperature (might be an existing alternative in NEMO?)
  • diawri.F90 (Modified)
    • Includes calls to dia_tmb and dia_25h
  • nemogcm.F90 (Modified)
    • calls the init routines for tmb and 25h respectively
  • dynspg_ts.F90 (Modified)
    • calls iom to output barotropic u,v

Testing

Testing could consider (where appropriate) other configurations in addition to NVTK].

SETTE TestedYES
Other model configurationsNO
Processor configurations tested[ Enter processor configs tested here ]
If adding new functionality please confirm that the
New code doesn't change results when it is switched off
and ''works'' when switched on
YES

(Answering UNSURE is likely to generate further questions from reviewers.)

'Please add further summary details here'

  • Processor configurations tested
  • etc——

Bit Comparability

Does this change preserve answers in your tested standard configurations (to the last bit) ? YES
Does this change bit compare across various processor configurations. (1xM, Nx1 and MxN are recommended)YES
Is this change expected to preserve answers in all possible model configurations?YES
Is this change expected to preserve all diagnostics?
,,''Preserving answers in model runs does not necessarily imply preserved diagnostics. ''
YES

If you answered '''NO''' to any of the above, please provide further details:

  • Which routine(s) are causing the difference?
  • Why the changes are not protected by a logical switch or new section-version
  • What is needed to achieve regression with the previous model release (e.g. a regression branch, hand-edits etc). If this is not possible, explain why not.
  • What do you expect to see occur in the test harness jobs?
  • Which diagnostics have you altered and why have they changed?Please add details here……..

System Changes

Does your change alter namelists? YES
Does your change require a change in compiler options?NO

If any of these apply, please document the changes required here…….


Resources

''Please ''summarize'' any changes in runtime or memory use caused by this change……''


IPR issues

Has the code been wholly (100%) produced by NEMO developers staff working exclusively on NEMO?YES

If No:

  • Identify the collaboration agreement details
  • Ensure the code routine header is in accordance with the agreement, (Copyright/Redistribution? etc).Add further details here if required……….
Last edited 6 years ago by deazer (previous) (diff)

comment:3 Changed 5 years ago by deazer

Merged in Trunk at revision number 5253

comment:4 Changed 4 years ago by nicolasmartin

  • Keywords tides added; Tide removed

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords mean added; Mean removed

comment:6 Changed 4 years ago by nicolasmartin

  • Keywords 25hr_mean added; 25 hour mean removed

comment:7 Changed 3 years ago by timgraham

  • Resolution set to fixed
  • Status changed from new to closed

This functionality is now in the trunk

comment:8 Changed 3 years ago by nemo

  • Type changed from Development to Task

Remove 'Development' type

Note: See TracTickets for help on using tickets.