Opened 6 years ago

Closed 6 years ago

#1337 closed Bug (fixed)

Bug in bdytides.F90

Reported by: nemo_user Owned by: nemo
Priority: highest Milestone:
Component: OCE Version: release-3.6
Severity: Keywords:
Cc:

Description

The presence of dta_bdy with 2D variables(ssh/u2d/v2d) is inconsistent and/or dta_bdy is just not allocated with such variables to be used in bdytides.F90

! If time splitting, save data at first barotropic iteration

IF ( PRESENT(kit) ) THEN
               IF ( lk_first_btstp ) THEN ! Save slow varying open boundary data:
                  dta_bdy_s(ib_bdy)%ssh(1:ilen0(1)) = dta_bdy(ib_bdy)%ssh(1:ilen0(1))
                  dta_bdy_s(ib_bdy)%u2d(1:ilen0(2)) = dta_bdy(ib_bdy)%u2d(1:ilen0(2))
                  dta_bdy_s(ib_bdy)%v2d(1:ilen0(3)) = dta_bdy(ib_bdy)%v2d(1:ilen0(3))

               ELSE ! Initialize arrays from slow varying open boundary data:            
                  dta_bdy(ib_bdy)%ssh(1:ilen0(1)) = dta_bdy_s(ib_bdy)%ssh(1:ilen0(1))
                  dta_bdy(ib_bdy)%u2d(1:ilen0(2)) = dta_bdy_s(ib_bdy)%u2d(1:ilen0(2))
                  dta_bdy(ib_bdy)%v2d(1:ilen0(3)) = dta_bdy_s(ib_bdy)%v2d(1:ilen0(3))
               ENDIF
            ENDIF

Commit History (1)

ChangesetAuthorTimeChangeLog
4758jchanut2014-09-05T14:13:33+02:00

Change to allow tides and frs, see ticket #1337

Change History (3)

comment:1 Changed 6 years ago by jchanut

The problem is not very clear from your description.
I found that, indeed, if you have tides but you do not use flather scheme, there is a problem. Because dta_bdy%ssh is not allocated in that case.

comment:2 Changed 6 years ago by jchanut

  • Version changed from nemo_v3_4 to nemo_v3_6_alpha

Corrected at revision 4758.
This change allows to have tides and not only a Flather scheme at open boundaries. This removes the above issue due to unallocated ssh arrays.
Still, reading ssh data at open boundaries is required even if a Flather scheme is not used (should be changed in the future although such a situation in realistic applications is unlikely).
http://forge.ipsl.jussieu.fr/nemo/changeset/4758

comment:3 Changed 6 years ago by jchanut

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.