Opened 6 years ago

Closed 5 years ago

#1376 closed Bug (fixed)

AGRIF does not run with north fold

Reported by: jchanut Owned by: mocavero
Priority: normal Milestone: 2015 WP
Component: AGRIF Version: release-3.6
Severity: Keywords:
Cc:

Description

ORCA2-LIM does not run anymore when compiled with key_agrif and no zoom* (on has also to remove key_zdfddm which is an other problem).
It seems that it comes from recent changes in the North-fold condition because it used to work before. Reverting to cyclic east-west periodicity is ok.

*In order to do so, one has to change "1" into "0" in the first line of AGRIF_FixedGrids.in file.

Commit History (0)

(No commits)

Change History (9)

comment:1 Changed 6 years ago by mocavero

When you said "recent changes", did you refer to the north-fold optimization?
If yes, please can you try with/out the optimization (ln_nogather=T/F)?

comment:2 Changed 6 years ago by jchanut

With or without, that's the same (well, without the model runs 14 time steps instead of 1).
No matter optimization is used or not, it is likely that Agrif converter produces something wrong with the new code.

comment:3 Changed 6 years ago by mocavero

It seems to be a problem related to the North-fold algorithm. We worked only on north-fold performance optimization without changing the algorithm. After the solution of the problem on the algorithm (running without optimization), we could check if the optimization is ok.

comment:4 Changed 6 years ago by clevy

  • Milestone set to 2015 new developments
  • Owner changed from NEMO team to mocavero

comment:5 Changed 6 years ago by mocavero

I ran the ORCA2AGUL_1_2 SETTE configuration.

I had the following error due to the activation of key_diaobs, so I removed the key from the ORCA2AGUL_1_2 test and it worked.

Type of vertical interpolation method n1dint = -2080839632
Type of horizontal interpolation method n2dint = -2080839632

==⇒>> : W A R N I N G

===============

key_diaobs is activated but logical flags ln_t3d, ln_s3d, ln_sla, ln_ssh, ln_sst, ln_sss, ln_seaice, ln_vel3d are all set to .FALSE.

==⇒>> : E R R O R

===========

Choice of vertical (1D) interpolation method
is not available

==⇒>> : E R R O R

===========

Choice of horizontal (2D) interpolation method
is not available

I tried changing "1" into "0" in the first line of the AGRIF_FixedGrids.in file, with and without the north-fold optimization (ln_nnogather=T/F). I was not able to reproduce your problem: all the time steps (75) have been executed, but I had a problem during the restart writing phase. However, I believe this is not related to the north fold algorithm and its optimization.

comment:6 Changed 6 years ago by jchanut

Did you test several mpp decompositions ? If not, what is yours ?

comment:7 Changed 6 years ago by mocavero

Before my previous comment I tried with the following decompositions:

jpni = 8 and jpnj=2
jpni = 2 and jpnj=8
jpni = 16 and jpnj=4
jpni = 4 and jpnj=16

and they worked well. Today I have tried with jpni=32 and jpnj=4 and jpni=4 and jpnj=32, they failed at the first time step (with and without the north fold optimization). However, without activating the north fold optimization flag, the old code is executed, so the error should be not related to the new code.

comment:8 Changed 6 years ago by mocavero

I updated the code to revision 5107 and also decompositions jpni=32; jpnj=4 and jpni=4; jpnj=32 now work well. Could you try with the last code and give me some feedback?

comment:9 Changed 5 years ago by mocavero

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.