Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#1562 closed Bug (invalid)

fldread bug

Reported by: gmainsant Owned by: gmainsant
Priority: normal Milestone:
Component: OCE Version: release-3.6
Severity: Keywords: SBC allocation/deallocation
Cc:

Description

  • A bug appeared when the field 'land/sea mask filename' of the namsbc_core block namelist doesn't exist.

In this case, in the file fldread.F90 the code passes the condition line 1316 because the lsmfile value has a random value greater than 0.
After this condition, at the line 1338 the allocatable variable "ztmp_fly_dta" is not allocated before being used.

  • error message :

"forrtl: severe (408): fort: (8): Attempt to fetch from allocatable variable ZTMP_FLY_DTA when it is not allocated "

  • version : NEMO_3.6_STABLE
  • release : 5202

Commit History (0)

(No commits)

Change History (8)

comment:1 Changed 5 years ago by timgraham

Could you paste the line from your namelist_cfg here for the variable that is causing the problem?

If you don't have a land/sea mask file then it must be set to an empty string as in namelist_ref:

!              !  file name                    ! frequency (hours) ! variable  ! time interp. !  clim  ! 'yearly'/ ! weights                               ! rotation ! land/sea mask !
!              !                               !  (if <0  months)  !   name    !   (logical)  !  (T/F) ! 'monthly' ! filename                              ! pairing  ! filename      !
   sn_wndi     = 'u_10.15JUNE2009_fill'        ,         6         , 'U_10_MOD',   .false.    , .true. , 'yearly'  , 'weights_core_orca2_bicubic_noc.nc'   , 'Uwnd'   , ''

The reason for introducing namelist_ref and namelist_cfg is to avoid the need to allocate all namelist variables within the code.

comment:2 Changed 5 years ago by timgraham

  • Resolution set to invalid
  • Status changed from new to closed

After discussing with others in the systems team I think my comment above describes the cause of this error so it's not really a bug in the model. I will therefore close the ticket.

comment:3 Changed 4 years ago by nicolasmartin

  • Keywords allocation added; allocated removed

comment:4 Changed 4 years ago by nicolasmartin

  • Keywords SBC added; fldread removed

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords ztmp_fly_dta removed

comment:6 Changed 2 years ago by nemo

  • Keywords allocation/deallocation added; allocation removed

comment:7 Changed 2 years ago by nemo

  • Keywords release-3.6* added

comment:8 Changed 2 years ago by nemo

  • Keywords release-3.6* removed
Note: See TracTickets for help on using tickets.