Opened 5 years ago

Closed 3 years ago

#1612 closed Enhancement (fixed)

merge simplification branch onto trunk

Reported by: cetlod Owned by: nemo
Priority: low Milestone:
Component: OCE Version: trunk
Severity: Keywords:
Cc: Review:
MP ready?:
Progress:

Description

The simplification branch is now ready to be merged onto the trunk.
SETTE tests have been successfully passed.

Any branches created from now should start from the new simplified trunk

Commit History (3)

ChangesetAuthorTimeChangeLog
5861gm2015-11-05T12:59:33+01:00

#1612 : correct a bug in dynldf_lap_blp in vvl case: forgot en e3t_b

5860gm2015-11-05T11:53:41+01:00

#1612 : correct a bug in dynldf_lap_blp in vvl case and a minor bug in sbcwave

5836cetlod2015-10-26T15:49:40+01:00

merge the simplification branch onto the trunk, see ticket #1612

Change History (4)

comment:1 Changed 5 years ago by gm

In  revision 5860 2 bugs has been corrected:

(1) - a major bug : in dynldf_lap_blp.F90  the e3 scale factors in the divergence calculation should be label as before fields

(2)- a minor bug : in sbcwave.F90,  wrong index in meridian stokes drift calculation (thanks to Emanuela clementi)

comment:2 Changed 5 years ago by gm

Forgot to change a fse3t into fse3t_b  in dynldf_lap_blp.F90  =⇒>  revision 5861  

comment:3 Changed 5 years ago by acc

Just to confirm that, with the fixes introduced at revision 5861, the trunk now passes all the full SETTE tests:

GYRE        restartability  passed
ORCA2LIMPIS restartability  passed
ORCA2OFFPIS restartability  passed
AMM12       restartability  passed
ORCA2LIM3   restartability  passed
SAS         restartability  inconclusive (  solver.stat  not found )
GYRE        reproducibility passed
ORCA2LIMPIS reproducibility passed
ORCA2OFFPIS reproducibility passed
AMM12       reproducibility passed
ORCA2LIM3   reproducibility passed
ORCA2_LIM_OBS   reproducibility passed
SAS         reproducibility inconclusive (  solver.stat  not found )
ORCA2_LIM_AGRIF runability passed
ORCA2_LIM_AGRIF code corruption test passed

The only exceptions being the ISOMIP tests which no longer compile due to incompatibilities in the source modules downloaded into MY_SRC from this external configuration.

Additional, 3 year integrations of ORCA2LIMPIS and ORCA2LIM3 were also successfully completed to confirm longer term stability.

comment:4 Changed 3 years ago by clevy

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.