Opened 4 years ago

Closed 18 months ago

#1785 closed Bug (wontfix)

reproductibility with tke / dependence on the number of subdomains

Reported by: julienjouanno Owned by: rbourdal
Priority: normal Milestone:
Component: OCE Version: release-3.6
Severity: minor Keywords: TKE
Cc: rbourdal

Description

Context

Setup of regional configuration with bdy / tke / ubs on momentum / fct for tracers / trunk (version 6980)

Results depends on the number of subdomains.

It seems to works fine when using small number of subdomain (e.g. jpnij=80; jpnj=10,jpni=8) whereas the use of large number of procs (> 100) leads to very strange results.
See figure that shows the surface meridional velocity when using 10x8 subdomains (top) and 20x8 subdomains (bottom).

Analysis

  • The error is not dependent of the machine (same problem on both curie and occigen supercomputers)
  • Using GLS instead of TKE resolve this issue (solution does not depend on the nuùmber of subdomains)
  • We see a strong imprint of the wind stress field in the corrupted case (bottom figure) additionaly suggesting that this is an issue with zdf/tke.
  • Figures are shown for a case that do not use key_agrif, but when using an agrif zoom, only the parent grid seems to be affected

Commit History (0)

(No commits)

Attachments (3)

voce_8x10_vs_9x20.png (99.3 KB) - added by julienjouanno 4 years ago.
meridional surface velocity after a few days of simulation
compare_agrif_4x10_vs_14x10.png (232.2 KB) - added by julienjouanno 4 years ago.
zonal surface velocity in the parent grid when using agrif : 4x10 subdomains (top) vs 14*10 subdomains (bottom)
namelist_cfg.1 (30.0 KB) - added by julienjouanno 4 years ago.
namelist

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by julienjouanno

meridional surface velocity after a few days of simulation

Changed 4 years ago by julienjouanno

zonal surface velocity in the parent grid when using agrif : 4x10 subdomains (top) vs 14*10 subdomains (bottom)

Changed 4 years ago by julienjouanno

namelist

comment:1 Changed 4 years ago by nicolasmartin

meridional surface velocity after a few days of simulation zonal surface velocity in the parent grid when using agrif : 4x10 subdomains (top) vs 14*10 subdomains (bottom)

Probably the ticket is much readable now with images rendering directly in the ticket.
Just a trick for further use.

comment:2 Changed 3 years ago by clevy

  • Owner changed from nemo to rbourdal

comment:3 Changed 3 years ago by clevy

  • Cc rbourdal added
  • Status changed from new to assigned

comment:4 Changed 3 years ago by cbricaud

I tried to reproduce this bug with trunk rev 8583
I used AMM12 reference configuration ( bdy), switched it from gls to tke, and to UBS adv scheme for dynamics
I compared 4*8 and 8*4 for MPI splitting, then 10*12 and 12*10

The configuration is reproductible for these tests and the "strange" paterns doesn't appear

comment:5 Changed 18 months ago by gsamson

  • Resolution set to wontfix
  • Severity set to minor
  • Status changed from assigned to closed

As Clément Bricaud did not succeed in reproducing Julien bug with AMM12 and a newer revision of the trunk (r8583 vs r6980), I consider either that the bug was fixed somewhere between the 2 revisions, either that we don't have enough elements from Julien configuration to reproduce the bug. So I close the ticket.

Note: See TracTickets for help on using tickets.