Opened 3 years ago

Closed 20 months ago

Last modified 5 months ago

#1876 closed Bug (wontfix)

Missing initialisation of array 'rnf_b'; river runoff not taken into account in the reconstruction of the nonlinear trajectory

Reported by: sam Owned by:
Priority: low Milestone:
Component: TAM Version: release-3.4
Severity: minor Keywords: TAM
Cc:

Description

Context

Following a change of the value of a namelist parameter that should not have any effect on the state variables during the model run, the tangent-linear model unexpectedly produced a rapidly growing, unrealistic tracer distribution that indicated numerical instability.

Analysis

The numerical instability appeared to be caused by unrealistic vertical velocities of the nonlinear trajectory. Subsequent analysis revealed that one of the arrays representing river runoff, 'rnf_b', which affects the reconstruction of the vertical velocity field of the nonlinear trajectory via subroutine 'ssh_wzv' (which is called during each update of the nonlinear trajectory), is left uninitialised during model runs. The other array representing river runoff, 'rnf', is initialised with values of zero during model initialisation, but it is also not updated as part of the nonlinear trajectory during the tangent-linear time step or its adjoint. Thus, for configurations with explicit forcing of river runoff, if array 'rnf_b' would be initialised with values of zero the vertical velocity fields of the nonlinear trajectory would still be incorrectly reconstructed at locations where river runoff is non-zero.

Fix

If the vertical velocity field of the nonlinear trajectory is reconstructed via a call to subroutine 'ssh_wzv' in 'trj_tam', then array 'rnf_b' needs to be initialised before the first call to 'ssh_wzv' takes place.

Initialisation of array 'rnf_b' with values of zero throughout would result in an approximate trajectory where explicit river runoff is not taken into account. In order to take river runoff into account correctly, both 'rnf' and 'rnf_b' could be added to the nonlinear-trajectory output files, and read in and interpolated along with the other variables of the nonlinear trajectory in subroutine 'trj_tam'.

Commit History (1)

ChangesetAuthorTimeChangeLog
11809smueller2019-10-26T14:15:48+02:00

Inclusion of river runoff (arrays rnf and rnf_b of module sbc_oce) in the nonlinear-model trajectory used by NEMOTAM; elimination of the use of an uninitialised array (array rnf_b of module sbc_oce) in the reconstruction of the vertical velocity field of the nonlinear-model trajectory used by NEMOTAM (fix for the bugs described in ticket #1876)

Change History (7)

comment:1 Changed 3 years ago by nicolasmartin

  • Owner nemo deleted
  • Status changed from new to assigned

comment:2 Changed 3 years ago by nicolasmartin

  • Status changed from assigned to new

comment:3 Changed 2 years ago by nemo

  • Keywords release-3.4* added; nemo_v3_4* removed

comment:4 Changed 2 years ago by nemo

  • Keywords release-3.4* removed

comment:5 Changed 2 years ago by nicolasmartin

  • Priority changed from normal to low
  • Severity set to minor

The 3.4 release is no longer supported: if relevant the version at stake must be updated (release-3.6 or trunk for upcoming 4.0), if not close the ticket.

comment:6 Changed 20 months ago by nicolasmartin

  • Resolution set to wontfix
  • Status changed from new to closed

I close the ticket because it is solely the last one on the v3.4 and anyway we are not going to commit any bugfix on the release code.

comment:7 Changed 5 months ago by smueller

In 11809:

Inclusion of river runoff (arrays rnf and rnf_b of module sbc_oce) in the nonlinear-model trajectory used by NEMOTAM; elimination of the use of an uninitialised array (array rnf_b of module sbc_oce) in the reconstruction of the vertical velocity field of the nonlinear-model trajectory used by NEMOTAM (fix for the bugs described in ticket #1876)

Note: See TracTickets for help on using tickets.