Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#1881 closed Task (worksforme)

Met_Office-1 Use XIOS to read single file restart file

Reported by: andmirek Owned by: andmirek
Priority: low Milestone:
Component: OCE Version: release-3.6
Severity: minor Keywords: XIOS read/write
Cc: Review:
MP ready?:
Progress:

Description

Context

This development is to add functionality to read single file restart with XIOS

Analysis

Currently for a single file restart all processors open the file and read corresponding data. This method becomes inefficient when large number of processors is used to run NEMO. Recent XIOS version (ver. 2) has the capability to read data. This capability may be used to read restart if needed. This would be an addition to the existing reading functionality, activated through the variable in the namelist. https://forge.ipsl.jussieu.fr/nemo/wiki/2017WP/Met_Office-1_Mirek_XIOSread

Fix


Commit History (3)

ChangesetAuthorTimeChangeLog
9424andmirek2018-03-23T09:57:45+01:00

#1881 initialize multidimensional array to 0 for XIOS read in iom_get_123d

8293andmirek2017-07-06T17:29:08+02:00

#1881: Add 2 missing variables in restart.

8242andmirek2017-06-29T10:51:48+02:00

#1881 fix restart path name

Change History (12)

comment:1 Changed 3 years ago by andmirek

  • Version changed from trunk to nemo_v3_6_STABLE

Branch created: branches/UKMO/dev_r5518_GO6_package_XIOS_read: https://forge.ipsl.jussieu.fr/nemo/log/branches/UKMO/dev_r5518_GO6_package_XIOS_read. Restart read functionality works and there is no need to define file in the new context in iodef.xml. iodef.xml (and other xml files) modified in CONFIG/GYRE_XIOS/EXP00/domain_def.xml to provide a template for use of xios read functionality.

UKMO suite: u-al584

Last edited 3 years ago by andmirek (previous) (diff)

comment:2 Changed 3 years ago by andmirek

revision 8153 disables reading restart with xios when AGRIF is used. SETTE test resulted in error: "Incoherent data received from servers, expected 2 chunks but 1 were given." Similar error was reported by Samantha Adams in a different context (see XIOS mailing list in June 2017: Can anyone help with the meaning of this error message?). The possible reasons for this error were given, but I can not relate any of them to this case.

comment:3 Changed 3 years ago by clevy

  • Owner changed from nemo to andmirek
  • Type changed from Enhancement to Task

comment:4 Changed 3 years ago by andmirek

  • Severity set to minor
  • Status changed from new to assigned

With the latest commit @8293 this branch works with Agrif. Performance of the read interface is far from perfect for high resolution (GO6, ORCA12 - Met Office?) configurations. There are also failures when reading restart for large number of processors. Reading functionality works when domain is decomposed using up to 60x60 processors (with land suppression on), but fails when 70x70 (or more) is used. For ORCA25 XIOS read interface works fine up to 1440 processors, but is slower than reading single file restart with default NEMO interface.

For a single restart file XIOS can almost match default NEMO read functionality, but the interface is slower than reading multiple restart files (each processor is reading its own domain).

Met Office? twiki page: http://www-twiki/Main/GO6eORCA12TechnicalImprovements

Last edited 3 years ago by andmirek (previous) (diff)

comment:5 Changed 3 years ago by andmirek

  • Resolution set to worksforme
  • Status changed from assigned to closed

#1953 documents development for WP2017

comment:6 Changed 3 years ago by nicolasmartin

  • Summary changed from Use XIOS to read single file restart file to Met_Office-1 Use XIOS to read single file restart file

comment:7 Changed 2 years ago by nemo

  • Keywords XIOS added; xios removed

comment:8 Changed 2 years ago by nemo

  • Keywords read/write added; read removed

comment:9 Changed 2 years ago by nemo

  • Keywords release-3.6* added

comment:10 Changed 2 years ago by nemo

  • Keywords release-3.6* removed

comment:11 Changed 2 years ago by andmirek

In 9424:

#1881 initialize multidimensional array to 0 for XIOS read in iom_get_123d

comment:12 Changed 2 years ago by andmirek

  • Milestone 2017 WP deleted

A problem was encountered when testing performance of XIOS read interface for ORCA12 with land suppression. For some decomposition solver didn't converge (with Na Ns?) on the first timestep. The problem is most likely related to the way XIOS reads data (must be doing it differently than default NEMO interface). Setting output arrays to 0 in iom_get_123d resolved the issue. But in the future use of appropriate masks may need to be considered. Fix is in revision 9424. The same fix fill have to be applied to the trunk.

Note: See TracTickets for help on using tickets.