Opened 3 years ago

Closed 3 years ago

#1887 closed Bug (fixed)

AGRIF tests failing with segmentation fault

Reported by: timgraham Owned by: nemo
Priority: normal Milestone:
Component: AGRIF Version: trunk
Severity: Keywords: segfault
Cc:

Description

Context

At the head of the trunk the ORCA2AGUL cases are failing with segmentation faults on our machine. Note that this is different to #1865 which is a compilation error when using TOP with AGRIF.

Analysis

The last successful test that I have run is at r7765 of the trunk. I'll run further tests at revisions in between to try to find the cause of the problem.

Fix


Commit History (1)

ChangesetAuthorTimeChangeLog
7933timgraham2017-04-19T14:33:11+02:00

Fix for #1887 to run ORCA2AGUL tests with LIM3 without segmentation faults

Change History (4)

comment:1 Changed 3 years ago by timgraham

Further tests show that this has been broken since r7816. However r7816 was a bug fix for a compilation error introduced at r7788 so AGRIF can't be compiled in between these revisions.

comment:2 Changed 3 years ago by timgraham

r7788 with the bug fix applied to sbcisf.F90 at r7816 also segfaults.

comment:3 Changed 3 years ago by timgraham

It turns out that my earlier test at r7765 wasn't compiled with LIM3. Compiling with LIM3 caused it to fail with a seg fault.

I've now discovered that the problem is due to issues in the setup of the ORCA2AGUL configuration. Specifically, the following changes are needed:

1) Copy namelist_ice_ref to 1_namelist_ice_ref
2) In 1_namelist_ice_cfg set nn_ice=3 (note that it used to be possible to set this to zero when using LIM2)
3) Set nn_fsbc=1 on both grids
4) Set nn_cln_update=1 in 1_namelist_cfg

Last edited 3 years ago by timgraham (previous) (diff)

comment:4 Changed 3 years ago by timgraham

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in trunk at r7933

Note: See TracTickets for help on using tickets.