Opened 12 years ago

Closed 12 years ago

Last modified 3 years ago

#211 closed Bug (fixed)

compilation error when key_trddyn is active related to the dynamics advection flux formulation

Reported by: ctlod Owned by: nemo
Priority: low Milestone:
Component: OCE Version: trunk
Severity: Keywords: TRD advection fluxes
Cc:

Description (last modified by ctlod)

The problem is related to the dynadv_cen2.F90 and dynadv_ubs.F90 modules in which call sequences to trd_mod doesn't exist.

Commit History (1)

ChangesetAuthorTimeChangeLog
1129ctlod2008-06-24T08:45:37+02:00

trunk: compilation error when key_trddyn is active related to the dynamics advection flux formulation, see ticket: #211

Change History (6)

comment:1 Changed 12 years ago by ctlod

Now, the horizontal & vertical advection trends are saved through a CALL to trd_mod() subroutine.
So they are taken into account when checking integral constrains properties (key_trddyn cpp key).
BUT Notice that if using vorticity trends (key_trdvor) a warning is printed when the horizontal advection trend
should be treated since no tests have been done in case of using flux formulation for the dynamics advection.

comment:2 Changed 12 years ago by ctlod

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from compilation error when key_trddyn is active related to dynadv.F90 to compilation error when key_trddyn is active related to the dynamics advection flux formulation

comment:3 Changed 4 years ago by nicolasmartin

  • Keywords fluxes added; flux removed

comment:4 Changed 4 years ago by nicolasmartin

  • Keywords TRD added; trends removed

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords formulation added; form removed

comment:6 Changed 3 years ago by nemo

  • Keywords formulation removed
Note: See TracTickets for help on using tickets.