Opened 2 months ago

Closed 2 months ago

#2517 closed Defect (fixed)

Activation of option to use ice restart file for initial ice conditions when ln_rstart = .false.

Reported by: acc Owned by: acc
Priority: low Milestone: Unscheduled
Component: SI3 Version: release-4.0
Severity: minor Keywords: release-4.0-HEAD, ice
Cc:

Description

Context

The ice initialisation options includes a nn_iceini_file = 2 option which is meant to allow ice initial conditions to be read from a restart file (even when ln_rstart is false) but this option is not working in v4.0.3. The option is not present in the trunk version.

Analysis

The relevant code in icestp.F90 is:

      IF ( ln_rstart .OR. nn_iceini_file == 2 ) THEN 
         CALL ice_rst_read                      ! start from a restart file
      ELSE
         CALL ice_istate_init
         CALL ice_istate( nit000 )              ! start from rest or read a file
      ENDIF

but this won't work because nn_iceini_file isn't set until ice_istate_init, so this needs to be:

      CALL ice_istate_init
      IF ( ln_rstart .OR. nn_iceini_file == 2 ) THEN
         CALL ice_rst_read                      ! start from a restart file
      ELSE
         CALL ice_istate( nit000 )              ! start from rest or read a file
      ENDIF

Recommendation

In 4.0-HEAD, Make the simple change above and there is also an opportunity to tidy code inside icerst.F90 to remove a (now) redundant call to ice_istate_init.

Commit History (1)

ChangesetAuthorTimeChangeLog
13445acc2020-09-01T18:25:07+02:00

r4.0-HEAD. Simple fix to enable the nn_iceini_file=2 option to work as intended. This fixes #2517

Change History (1)

comment:1 Changed 2 months ago by acc

  • Resolution set to fixed
  • Status changed from new to closed

In 13445:

r4.0-HEAD. Simple fix to enable the nn_iceini_file=2 option to work as intended. This fixes #2517

Note: See TracTickets for help on using tickets.