Opened 7 weeks ago

Closed 5 weeks ago

#2545 closed Bug (fixed)

bug in heat budget for SI3

Reported by: clem Owned by: systeam
Priority: low Milestone:
Component: SI3 Version:
Severity: major Keywords:
Cc:

Description

Context

they are several flaws in the way SI3 treats its heat exchanges with the ocean.

1) heat conservation is not ensured while landfast is activated because we switched off the production of ice in the leads (in icethd_do.F90) without setting qlead to 0 when ice is thick enough to have friction on the sea floor (tau_icebfr/=0, icethd.F90).
Also, switching off ice formation as soon as there is friction whatever the ice velocity or the ice concentration is not very smart. It was done to avoid a continuous formation of ice when ice is grounded.

=⇒ solution 1: set qlead to 0 and no ice production in the leads where there is friction (tau_icebfr/=0) and ice concentration is close to its maximum value (rn_amax)

=⇒ solution 2 (better?): set qlead to 0 and no ice production in the leads where ice velocity drops below 5.e-04 m/s (commonly accepted value for landfast) and ice concentration is close to its max value (rn_amax)

2) There is a mixed up between solar and non-solar fluxes reaching the ocean after ice thermodynamics, though the total heat is conserved (see iceupdate.F90). Both solar and non solar fluxes reaching the leads are used to melt sea ice, so this energy is somewhat lost for the ocean to increase its temperature. However, at the end, the ocean will still see the total solar flux that reached the leads while the non-solar is adapted to conserve heat.

=⇒ solution: consider that the solar flux which has reached the 1st level of the ocean is entirely consumed by the ice when the ocean is warming up and there is still some ice left.

3) The parameterization of lateral melting (icethd_da.F90) does not depend on any heat balance (contrary to basal and surface melting). It only depdends on the difference of temperature between the ocean and ice. Therefore, we can temporarily end up with a local supercooling.

=⇒ solution: none.

At least the first 2 defects must imperatively be corrected in 4.0 and the trunk

Commit History (2)

ChangesetAuthorTimeChangeLog
13643clem2020-10-20T01:41:14+02:00

trunk: use the transmitted solar for the ice budget. See #2545

13642clem2020-10-20T00:58:34+02:00

4.0-HEAD: use the transmitted solar for the ice budget. See #2545

Change History (7)

comment:1 Changed 7 weeks ago by clem

It seems that the problem of heat conservation is larger than previously thought. The way we have written the heat reaching the ocean (qt_oce_ai) is not strictly conservative. Based on orca2 simulations, heat unbalance is probably between 0.01 and 0.1 W/m2. I will evaluate it more accurately. So what I did or will do is 1) code diagnostics for heat unbalance with an output file the same way as for cfl diags, 2) change qt_oce_ai to have a perfectly conservative system, and 3) commit those changes in 4.0 and in the trunk asap. It will touch at least 3 or 4 ice routines but namelists and xml will not be changed (at least in 4.0), so that it is transparent for a user.

comment:2 Changed 6 weeks ago by clem

solved at r13589 for r4.0-HEAD

comment:3 Changed 6 weeks ago by clem

  • Resolution set to fixed
  • Status changed from new to closed

fixed at r13602 for the trunk

comment:4 Changed 6 weeks ago by clem

  • Resolution fixed deleted
  • Status changed from closed to reopened

reopened since there is still a contradiction in the use of solar flux for the ice heat budget, though it is not a bug.
In a warming period, we use the solar flux from the leads to melt sea-ice but we do not take into account the solar transmitted trhu the ice. We leave this one to the next time step (so it will warm the ocean first). I am currently testing the inclusion of this transmitted solar flux into the ice heat budget. If this is conclusive, I'll commit it for 4.0-HEAD and the trunk

comment:5 Changed 6 weeks ago by clem

In 13642:

4.0-HEAD: use the transmitted solar for the ice budget. See #2545

comment:6 Changed 6 weeks ago by clem

In 13643:

trunk: use the transmitted solar for the ice budget. See #2545

comment:7 Changed 5 weeks ago by clem

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.