Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#954 closed Bug (fixed)

Bug in zdftke, zdfgls when used with zdfevd convection

Reported by: hadcv Owned by: rbourdal
Priority: low Milestone:
Component: OCE Version: release-3.2
Severity: Keywords: TKE ZDF
Cc:

Description

Enhanced diffusion coefficients when using the zdfevd module to boost both avt and avm (nn_evdm=1) cause excessive mixing under convection in the 'new' TKE scheme introduced in NEMO 3.2.

This version was written so that diffusion coefficients from the previous timestep are used to calculate the current TKE. However this inherits the arbitrary zdfevd-boosted coefficients, which greatly increases the production terms of the TKE budget, in places tripling the mixed layer depth.

This is mainly a problem for forced configurations, coupled configurations do not seem to be notably impacted. This is also a problem in zdfgls in theory, though this has not been tested.

Currently, this can be addressed in two ways (see attached figure):

  1. Remove the contribution to avt/avm from zdfevd at the start of zdftke
  1. Set nn_evdm=0 so that avm is not boosted

We (UKMO) currently follow method 1, but it is not clear whether the contributions from zdftmx and zdfddm should also be removed so that the TKE budget is energy conserving.

Commit History (1)

ChangesetAuthorTimeChangeLog
3406rblod2012-06-05T18:32:34+02:00

First fix for tke bug, see ticket #954

Attachments (1)

MLD_PAPA_convbug_various.png (328.2 KB) - added by hadcv 9 years ago.
Forced testing at ORCA1 resolution

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by hadcv

Forced testing at ORCA1 resolution

comment:1 Changed 9 years ago by rbourdal

  • Owner changed from NEMO team to rbourdal

Hi,

There is the same problem in the nemo version 3_4.
The problem is the same if zdftmx and/or zdfddm are actived but the impact is less critical.

Another solution is to use 4 another new 3D arrays to stock the turbulent coefficients needed (avm_zmix, avt_zmix, avmu_zmix, avmv_zmix, all declared in save). And you run tke or gls with these new coeff. At the end of TKE or GLS you make avm = avm_zmix, avt=avt_zmix,…
With this solution tmx and ddm have any impact on the turbulent closure solution.

note: enhanced vertical diffusion option should not be used with gls because stability functions are included in GLS working in instable cases.

comment:2 Changed 8 years ago by rblod

We (paris) think tke has to be self-consistent in any case (tmx,ddm). Since it's quiet a huge bug I've fixed it for nemo 3.4 changeset:3406, following Romain suggestion. I haven't change GLS. A more extensive fix could be to remove avmu,avmv and recompute it when used (or have fortran substitute), in order to save memory. So I let the ticket open for now.

comment:3 Changed 8 years ago by rbourdal

  • Resolution set to fixed
  • Status changed from new to closed

add same modifications than TKE to have any impact of evd,tmx,ddm on the turbulent closure solution

Committed revision 3798

See changeset:
https://forge.ipsl.jussieu.fr/nemo/changeset/3798/branches/2012/dev_MERGE_2012

comment:5 Changed 4 years ago by nicolasmartin

  • Keywords TKE added; zdftke removed

comment:6 Changed 4 years ago by nicolasmartin

  • Keywords ZDF added; zdfevd zdfgls removed
Note: See TracTickets for help on using tickets.