Opened 20 months ago

Closed 8 months ago

Last modified 3 months ago

#2199 closed Task (fixed)

AGRIF-01_jchanut_small_jpi_jpj

Reported by: smasson Owned by: jchanut
Priority: normal Milestone: 2019 WP
Component: AGRIF Version: trunk
Severity: minor Keywords:
Cc: Review: passed
MP ready?: yes
Progress: Request for preview submitted on May 15

Description (last modified by jchanut)

Summary

Action AGRIF-01_jchanut_small_jpi_jpj
PI(S) Jérôme Chanut

Digest

Remove restriction on minimum domain size with AGRIF. AGRIF is indeed no more working if the mpi subdomain is so small that all boundary conditions cannot be done within the subdomain.
This happen in fact quite easily for the sponge layer

Dependencies
Expected for 2019WP
Ticket #2199
Branch NEMO/branches/2019/dev_r10973_AGRIF-01_jchanut_small_jpi_jpj
Previewer(s) S. Masson
Reviewer(s) S. Masson
wiki wiki:2019WP/AGRIF-01_jchanut_small_jpi_jpj

Abstract

AGRIF is no more working if the mpi subdomain is so small that all boundary conditions cannot be done within the subdomain.
This happen in fact quite easily for the sponge layer…

Commit History (14)

ChangesetAuthorTimeChangeLog
12965jchanut2020-05-25T09:34:57+02:00

Further nbondi/nbondj removal with AGRIF - results unchanged - forgotten in task #2199

12123jchanut2019-12-09T13:55:34+01:00

Merge devs from #2199 and #2222 in trunk

12120jchanut2019-12-09T12:03:44+01:00

2019 agrif update: #2199 and #2222

11580jchanut2019-09-20T10:10:54+02:00

#2199, remove useless boundary data interpolation at domain edges (used previously with 1 ghost cell and near boundary filtering)

11574jchanut2019-09-19T12:08:31+02:00

#2222, import changes from dev_r10973_AGRIF-01_jchanut_small_jpi_jpj (i.e. #2199)

11564jchanut2019-09-18T16:11:52+02:00

#2199, merged with trunk

11549jchanut2019-09-16T14:48:51+02:00

#2199: Take into account masked open boundaries in sponge definition. Output sponge values.

11542jchanut2019-09-13T15:27:41+02:00

#2199: 1) Replace TWO_WAY cpp key by namelist flag ln_agrif_2way. 2) Clean agrif_user module. At this stage, code is reproducible in one way mode down to jpi/jpj=3. Issues for small subdomain sizes (e.g. aprox < 7x7) remain in update (i.e. in 2 way mode). Masking of sponge in unconnected areas has to be implemented. -Cette ligne, et les suivantes ci-dessous, seront ignorées—

M src/NST/agrif_all_update.F90 M src/NST/agrif_user.F90 M src/NST/agrif_oce_sponge.F90 M src/NST/agrif_ice_update.F90 M src/NST/agrif_top_update.F90 M src/NST/agrif_oce.F90 M src/NST/agrif_oce_update.F90 M cfgs/SHARED/namelist_ref

11538jchanut2019-09-12T10:41:02+02:00

#2199, enforce ln_nnogather=.FALSE. if no periodic conditions. Some issues have been encountered in VORTEX test case.

11244jchanut2019-07-10T14:58:47+02:00

#2199, clean old namelist variables

11226jchanut2019-07-08T14:56:55+02:00

#2199, remove remaining use of nlcj

11219jchanut2019-07-05T14:07:17+02:00

#2199 1) Define aditionnal arrays to correct the time interpolation of barotropic arrays in corners. Since multiple stages in the time interpolation are necessary, overlapping segments in corners give wrong results otherwise (corrects stage 2 in previous commit).. 2) Added subroutine to correct time extrapolated fluxes at bdy in time splitting routine (updates stage 3 in previous commit). 3) Completly remove non-specified open boundary case. Boundares are now exactly set from parent (no more filtering nor extrapolation for outgoing flows). At this stage, use of nbondi, nbondj variables has been completly removed.

11205jchanut2019-07-02T14:25:46+02:00

#2199 1) Make sponge independent of sub-domain size. Partially masked open boundary segments are not taken into account anymore. To do so, sponge coefficients should be read in a file for realistic applications (then nesting tools need to be modified accordingly). 2) Replace East-West-North-South barotropic data arrays by a global 2d array. Then apply barotropic open boundary conditions thanks to mi0/mi1, mj0/mj1 indexes. 3) Call AGRIF bdy update one more time in dynspg_ts during extrapolation phase. This removes a dozen lines of code in dynspg_ts routine.

10979jchanut2019-05-15T10:19:30+02:00

Relax minimum domain size with AGRIF, #2199

Change History (21)

comment:1 Changed 20 months ago by smasson

  • Description modified (diff)

comment:2 Changed 19 months ago by nemo

  • Component changed from TOP to DOM
  • Priority changed from low to high

comment:3 Changed 18 months ago by jchanut

  • Component changed from DOM to AGRIF
  • Owner set to jchanut
  • Priority changed from high to normal
  • Status changed from new to assigned

comment:4 Changed 15 months ago by jchanut

In 10979:

Relax minimum domain size with AGRIF, #2199

comment:5 Changed 15 months ago by jchanut

  • Progress modified (diff)

comment:6 Changed 13 months ago by jchanut

In 11205:

#2199
1) Make sponge independent of sub-domain size. Partially masked open boundary segments are not taken into account anymore. To do so, sponge coefficients should be read in a file for realistic applications (then nesting tools need to be modified accordingly).
2) Replace East-West-North-South barotropic data arrays by a global 2d array. Then apply barotropic open boundary conditions thanks to mi0/mi1, mj0/mj1 indexes.
3) Call AGRIF bdy update one more time in dynspg_ts during extrapolation phase. This removes a dozen lines of code in dynspg_ts routine.

comment:7 Changed 13 months ago by jchanut

In 11219:

#2199
1) Define aditionnal arrays to correct the time interpolation of barotropic arrays in corners. Since multiple stages in the time interpolation are necessary, overlapping segments in corners give wrong results otherwise (corrects stage 2 in previous commit)..
2) Added subroutine to correct time extrapolated fluxes at bdy in time splitting routine (updates stage 3 in previous commit).
3) Completly remove non-specified open boundary case. Boundares are now exactly set from parent (no more filtering nor extrapolation for outgoing flows).
At this stage, use of nbondi, nbondj variables has been completly removed.

comment:8 Changed 13 months ago by jchanut

In 11226:

#2199, remove remaining use of nlcj

comment:9 Changed 13 months ago by jchanut

In 11244:

#2199, clean old namelist variables

comment:10 Changed 11 months ago by jchanut

  • Description modified (diff)
  • Summary changed from AGRIF-03_XXX_small_jpi_jpj to AGRIF-01_jchanut_small_jpi_jpj

comment:11 Changed 11 months ago by jchanut

In 11538:

#2199, enforce ln_nnogather=.FALSE. if no periodic conditions. Some issues have been encountered in VORTEX test case.

comment:12 Changed 11 months ago by jchanut

In 11542:

#2199: 1) Replace TWO_WAY cpp key by namelist flag ln_agrif_2way. 2) Clean agrif_user module. At this stage, code is reproducible in one way mode down to jpi/jpj=3. Issues for small subdomain sizes (e.g. aprox < 7x7) remain in update (i.e. in 2 way mode). Masking of sponge in unconnected areas has to be implemented.
-Cette ligne, et les suivantes ci-dessous, seront ignorées—

M src/NST/agrif_all_update.F90
M src/NST/agrif_user.F90
M src/NST/agrif_oce_sponge.F90
M src/NST/agrif_ice_update.F90
M src/NST/agrif_top_update.F90
M src/NST/agrif_oce.F90
M src/NST/agrif_oce_update.F90
M cfgs/SHARED/namelist_ref

comment:13 Changed 11 months ago by jchanut

In 11549:

#2199: Take into account masked open boundaries in sponge definition. Output sponge values.

comment:14 Changed 11 months ago by jchanut

In 11564:

#2199, merged with trunk

comment:15 Changed 11 months ago by jchanut

In 11574:

#2222, import changes from dev_r10973_AGRIF-01_jchanut_small_jpi_jpj (i.e. #2199)

comment:16 Changed 11 months ago by jchanut

In 11580:

#2199, remove useless boundary data interpolation at domain edges (used previously with 1 ghost cell and near boundary filtering)

comment:17 Changed 8 months ago by jchanut

In 12120:

2019 agrif update: #2199 and #2222

comment:18 Changed 8 months ago by jchanut

In 12123:

Merge devs from #2199 and #2222 in trunk

comment:19 Changed 8 months ago by jchanut

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:20 Changed 7 months ago by jchanut

  • MP ready? changed from no to yes
  • Review changed from failed to passed

comment:21 Changed 3 months ago by jchanut

In 12965:

Further nbondi/nbondj removal with AGRIF - results unchanged - forgotten in task #2199

Note: See TracTickets for help on using tickets.