Opened 3 months ago

Closed 3 months ago

#2565 closed Defect (fixed)

Unpaired / in namelists can cause issues

Reported by: acc Owned by: systeam
Priority: low Milestone:
Component: TOP Version:
Severity: minor Keywords:
Cc: Branch review: failed
MP ready?: no Task progress: Unspecified

Description

Context

Some of the namelists in the current trunk have an extra / which is not paired to and opening ampersand. E.g.:

!-----------------------------------------------------------------------
&namtrd        !   trend diagnostics                                    (default: OFF)
!-----------------------------------------------------------------------
/
!-----------------------------------------------------------------------
!-----------------------------------------------------------------------
/
!-----------------------------------------------------------------------
&namhsb        !  Heat and salt budgets                                 (default: OFF)
!-----------------------------------------------------------------------
/

This can cause issues. In tests on one system the namelist processing was stopped at this line (without error) meaning that subsequent settings were not used. Both the cause and effect can be difficult to detect so extra care is advised when uploading changes to namelists.

Analysis

A simple script such as this:

#!/bin/bash
for d in cfgs tests
do
  cd $d
  for nml in `find ./ -name '*namelist_*'`
  do
    namp=$(grep -c -e '^&' $nml)
    nsla=$(grep -c -e'^/' $nml)
    if test $namp -ne $nsla ; then
     echo 'irregularity ('$namp' to '$nsla') in '$d${nml:1}
    fi
  done
  cd ../
done

run in the top level directory has identified those namelists that needed changing

Recommendation

Exercise caution with changes to namelists and run this script before any releases

Commit History (1)

ChangesetAuthorTimeChangeLog
13731acc2020-11-05T21:28:53+01:00

Remove unpaired / from namelists. These changes fix #2565

Change History (1)

comment:1 Changed 3 months ago by acc

  • Resolution set to fixed
  • Status changed from new to closed

In 13731:

Remove unpaired / from namelists. These changes fix #2565

Note: See TracTickets for help on using tickets.